0
Answered

MD3 Firmware Problem?

Barnhart Crane 3 years ago updated by Ken Larsen 3 years ago 11

We currently have 4 MD3s that are 8 years old. When trying to upload an IQAN project file using a USB to CAN adapter they give no response, only error messages are transmitted to the CAN bus. I know my setup is wired correctly and there are no problems with it because I'm able to upload a project file to a different MD3 that our distributor put new firmware on a few years back.


Is this a firmware problem? if so, How is new firmware downloaded into an MD3? 

GOOD, I'M SATISFIED

Very fast and informative response. I'm impressed.

Satisfaction mark by Barnhart Crane 3 years ago

Could you tell me what software version is in the MD3 units now? You can check by going into the menu system and viewing info->modules->MD3. Also what version is the file you are trying to load into the MD3s?

There have been many new features added from IQANdesign 2 to IQANdesign 4. It is not possible to jump from 2 to 4 without loading a version 3 program first. That program should be loaded using the latest 3.19 software. Then a version 4 program may be loaded successfully.

The MD3s are using Version 1.33.12 


I just downloaded IQAN Design 3.19 and tried again and it still gave a "no master module found" error. Any other thoughts?

I also just downloaded IQAN Design 2.63 as well. I attempted uploading a project file using a usb connection as well as a USB to CAN adapter hooked into pins 4 and 9 (CAN C) and I was still not able to upload a file.


I see you have version 1.33 in the MD3s. That explains why CAN bus connection method does not work, CAN was introduced in version 2.00. Only USB will work. If your laptop is very new it is unknown if its USB will communicate with such an old version. Multi core processors and other PC advancements have changed USB somewhat.


I would try an earlier version of IQAN 2, it will have older USB drivers. It may be necessary to use IQANdesign 1.34 (the last of the 1.xx versions) first, but try IQAN 2.08 or 2.50. 

Ken,


Thanks for the response. Would it be better to just update the firmware on the MD3s so that I can use IQAN Design 4? Or is uploading a project file to the MD3 the means by which the firmware is updated? If not, how do you go about updating the firmware?

Correct, unfortunately the OS is sent with the application. You would need to find a way to connect over USB to be able to update from the old OS.

So now we've tried 2.63, 2.08, and 1.34. All give a similar response: "no handshake reply from master module" or "no master module found." I've also tried using an older laptop with no success.


Is there anything older than 1.34 that I can download?


When attempting to upload a project file, the screen on the MD3 goes black and some text appears saying it it deleting the current application, so I know that the wiring is correct. 

+1

Hmmm, if you can spare the module for a few days you could send it to me and I can try to communicate with it. If it is still not working and this will not be a problem send me an email at klarsen@parker.com.

Ken, thanks so much for the willingness to help. Our Parker distributor was able to use an old laptop and the oldest version of IQAN software he could find and he was able to jump our MD3s all the way up to version 4. 


Thanks again.

Excellent! That is what I would have been trying. Glad this is resolved.