0
Answered

Upload aplication (and firmware) with iqansync

Dingoma 2 years ago in IQANsync updated by Ulrik Zakariasson (Software development) 2 years ago 7

Hello.

I need to upload a Project to a machine with MD4+MC2 (via iqansync). The project was uploaded fine to the MC2, but I can't upload the project to MD4. It goes fine until 50%, but then starts to upload the firmware, and finally it stops and gives an error message. The size of the Project is 25mb.The original Project I suppose was made with 4.03 and the new one was made with 4.07.

Is there any possibility to upload Project (or at least firmware) with a usb pendrive or memory card?

GOOD, I'M SATISFIED

Thanks for your fast response.

This forum works really fine

Satisfaction mark by Dingoma 2 years ago
Under review

What is the error message?

What phone are you using (Android or iPhone)?

What version of IQANsync?


We do not support USB sticks or memory cards.

First of all, sorry for the delay in answering. I'm not sure about the error message, but I think it is something like "connection broken" or something similar.


The question is that after trying to send the app (and also after this thread was openend), I went to the machine, and the machine had the new application, so I think that what happened was that it taked a lot of time to upload the app and the firmware (>40mins), but it was done correctly, and after sending the app, there was a connection problem and this  is the message that we received. As changes between old and new versions are small (cycle time and some system information inputs) the operator can't know if the app is the new one or the older, so both assumed that it has the old one.

As we supposed that the upload of MC2 will be done very fast, but the firmware update will proceed very slowly, we (and also the operator) decided to do it a period of down time, so we only were taking 100% attention at the first 15 mins of the upload, so to be honest we really don't know exacly what happened, but what we think is that there was a connection problema with pone at any momento after finishing the upload.

Relative to other questions, we were using Android phone and the last version of Iqansync

In reference to the query of sdcard or usb stick, I know that currently is not posible to use it to upload apps, but maybe it could be an improvement that modules (or G11) could have the option to connect a usb stick with the new application and the master modules takes the app from the usb stick at the start up of the machine. In this way, the operator could have a usb stick with the original app, and we also can send by email the app to a computer, sabe it on pendrive and the upload must be faster (and not phone dependent)


So summarycing, I think there was an error, but the error is not the Iqansyn, so our question is solved

Answered

Thanks for the update. There is always a risk of wireless connections going offline, due to a number of different reasons. When updating MD4 firmware (i.e. switching minor and/or major version), it is probably wise to use a wired connection, or WiFi which is a lot faster than Bluetooth.

+1

We have learned to avoid firmware updates with iqansync(iPhone) (like Design v.4.xx -> to newer version) because updating have stopped so many times. So, we use laptop and an ethernet cable to update firmware and we use Iqansync only for small program updates (for same firmware systems).

Thanks for your comment Tuomas. We have learned the same... but as we had the machine near (not more than 30 km), we take the risk and tested the update with G11.

Currently, we use CAN to update the app (without firmware update) because we have a connector on dashboard, but if we must update firmware, we use the rear connector of the display.

I have made a test again, and result has been a bit extrange.
I went to the machine, and downloaded the application. I came to our Company, and made some changes on aplication. I tried to send again the application (all changes were made with 4.07), and it gone fine until the upload of the firmware arrived to 4/7. It takes more than an hour to arrive until 5/7. In fact, we disconected before it arrives, but after the operator switch off and on the machine, it has the last versión (the one that I have tried to upload) and it works fine!!!.
So, is it posible that Iqansync tries allways to send the firmware with the application (inclusive when the new one is the same than that is charged). Maybe the app was uploaded correctly, but the firmware not, but as the new one is the same that the old one, it works fine?
I know that it is not "correct" to upload firmware with Iqansync, but as G11 works so fine we are allways trying to do new things. 


Next week I will have a machine in our Company, so I will be able to make more test and check what really happen (during the upload the machine was stoped, so operator obviously didn't want to check how many time it takes to arrive to 5/7)


We have not been able to reproduce what you are describing in the same way. We did however find another way of causing a mismatch between different firmware parts by cancelling a firmware download and then continue the update with another firmware version. IQANdesign 5.01.35, which was released last week, fixes this issue.