0
Answered

G11 IQANsync Fail to connect via internet

Mitch Houle 4 years ago in IQANsync updated by Chris Radulescu 2 years ago 7

I have started using the G11 for remote diagnostics on a basic level until the point I have a better grasp on using it. We just installed it on one of our "Problem Child" machines as long as the tech was there. This was to not only test the system at a further distance than our shop floor to the office but to help dianose any future issues they may have. I had my Tech connect and we tried to communicate (see below clip). From my understanding I have everything correct and the g11 is up to date. I can find no trouble shooting documentation as how to diagnose or fix this issue.


Answer

+1
Answer

I believe this is the same problem that i have run into and its caused from not allowing connectivity under the security screen.

One the left hand side go into the Security tab and then into root. (as shown)



And here is a screen shot of the settings that should allow you to connect to the system through the G11 at any time. Make sure to select "Always" on all 3 of the connectivity options.




Hope this helps!

GOOD, I'M SATISFIED
Satisfaction mark by Mitch Houle 4 years ago
+1
Answer

I believe this is the same problem that i have run into and its caused from not allowing connectivity under the security screen.

One the left hand side go into the Security tab and then into root. (as shown)



And here is a screen shot of the settings that should allow you to connect to the system through the G11 at any time. Make sure to select "Always" on all 3 of the connectivity options.




Hope this helps!

C. Harp, Thank you that was exactly it.

Out of the three security properties for connectivity, this symptom is from the "Allow remote connection" property. (default on "Allow remote connection" is "Ask user", which does not work in applications without a master display).

I am trying to connect via cell phone remotely into the machine and I am getting the below message.

I've set the securities per the above comments, but it is still not working. My cellphone is connected via bluetooth to the G11 and I've located the IQANconnect Key in IQAN. I've purchased connections and gone through all the steps and all indications are that it can connect except that this message pops up. What are some of the common issues that people encounter with connecting that I should look out for? Am I missing something here? Thanks in advance,


The most plausible explanation for seeing the "No reply No handshake reply from master module" when you are sitting with IQANdesign and is connected via IQANconnect to an IQAN master  via G11+IQANsync is that the guy with IQANsync has exited the IQANsync app when you were about to send an update. 

If this is the case, you will see IQANdesign closes the remote connection, and when trying to reconnect the machine you were just connected to will show gray when trying reconnect. 


A more far-fetched explanation is one that can occur if you sit with a system on your bench and has connected the master to internet via IQANsync, and then instead used a local CAN connection to send an application. Then you will see this "no handshake reply" error dialogue in IQANdesign when trying to make a remote connection, and will have to restart to get the remote connection to work again.


A comment is that you should also have at least one more dialog box that could provide some more clues to what is going on. For example

"Opening session Failed to open a new communication session."

Gustav, thanks for the reply. We do get that second message as well (
"Opening session Failed to open a new communication session.") I am trying to connect to a machine that is in my possession before it ships so the cell phone I am using is in the IQANsync app and showing to be broadcasting properly. For some reason the computer side of things is just not wanting to connect no matter what I try. Any help would be appreciated.