Upgrading 2.x MD3/MC2 over USB not working in 4.04 or 4.05

When an IQAN-MC2 or IQAN-MD3 is loaded with version 2.x or a 3.x version < 3.12 it is not possible to connect to them to make an upgrade using IQANdesign/IQANrun version 4.04 or version 4.05


This is how the symptoms look in IQANrun 4.05




Both IQAN-MC2 and IQAN-MD3 are shipped with version 2.x, so this may pose problems when loading blank modules the first time.


Before version 4.06, the following alternatives worked

-Connect to the modules via CAN instead of USB. This is still the recommended way of connecting for best reliability.

-Using IdTag 0 at the MD3/MC2.

-Using IQANrun 3 or IQANdesign 3 to upgrade the module to 3.x, then continue with version 4.

-Using IQANrun 4.03 to send the version 4.04 or 4.05 project file. IQANrun 4.03 is found here.



The problem is now solved with IQANdesign/IQANrun version 4.06

This article was helpful for 6 people. Is this article helpful for you?