0
Fixed

Array channel - no resulting object

C. Drouaud 12 months ago in IQANdesign • updated by Ulrik Zakariasson (Software development) 8 months ago 6

Hello,


I have a problem with an array channel Qcode. I have 4 array channel really similar, but for one of them, a variable is not accepted and I have a "no resulting object error".

See below screenshots.


Array channel that works fine (Drilling data - depth) :

if PositiveFlank(New hole) then
Drilling data - depth[Hole number] := Depth MET
endif

Array channel that bugs (Drilling data - speed) : if PositiveFlank(New hole) then
Drilling data - speed[Hole number] := Mean speed
endif
Drilling data - speed [BUG]Both Qcode are the same axcept the variable. I try to re-write several times the code, I always select the variable from the suggested list.
For your information, I work with IQANdesign 4.07 version. It is not the forst time I have so weird error like that. Once, in a Math function, I had to add *1 not to have an error.
Thanks in advance for the help !

Under review

What does the error message say if you hover over the red lamps in the left gutter?

It says "Invalid identifier. Expecting identifier, constant, component, unary operator, function, statusof, statustypeof, (, vector, true or false".


The error is located on "Mean speed" variable, but I think the problem comes from the "Hole number" variable that is not recognized as a variable.

Could it be that the name of Mean speed ends with a space?

Yes ! You are right, I checked and it ended with a space. I removed it and now it works, no more error. 


Thanks for the help !

Good. I'll create a case so we can detect/handle this in future versions.

Fixed

Channel names are no longer allowed to start or end with white-space characters in IQANdesign 5.03.