0
Answered

Heap check failed warning

DavidH 2 years ago in IQANdesign updated by Ulrik Zakariasson (Software development) 2 years ago 6

I'm getting a warning in an IQANdesign project check for "Heap check failed"... "could not initialize embsup.dll".

I tried loading this code to an MD4-7, but the installation failed and the controller seemed to be stuck with partially loaded firmware, even after power cycling the unit multiple times. I pulled the address tag and was able to load an empty code to restore the unit.

This code started with an import of a few display pages along with their associated components (and MD4-7) that had been exported from another idax file. I was trying to isolate these display pages and test some ideas without the rest of the code involved.

Does anyone know why I'm getting this warning?

I'm using IQANdesign 5.02.13.4984

Thanks!

GOOD, I'M SATISFIED

Thanks for looking into this.

Satisfaction mark by DavidH 2 years ago
Under review

As part of the project check, IQANdesign intitialize the application in a way that is similar to how it runs on the real master. This is used for estimating memory utilization and to run the simulator. 

Since you already had it fail on the real master, it is clearly something in the application that will not work. 


Did you get it to run in IQANsimulate? It is not unlikely that IQANsimulate would generate a crash report when trying to simulate a project with this warning. 


It would be really great if you could send the application that does this so the developers to have a look at it. If this is possible, you could send it via https://iqan.sharefile.com/share/filedrop

I think that Ken L or someone else from the IQAN support team in the US  will get in touch with you

+1

I tried a few times to recreate the process that would generate this error, but I got inconsistent results so I wasn't able to isolate exactly what was causing this. I eventually abandoned this file and started over with a new project file. I found the file with the error in the recycle bin and sent it to your filedrop link.


Also, it does cause the simulator to crash, so I sent a crash report from that too.

+1

Thanks! 

I tried the file and could see the same result. As you guessed, it is probably caused by something going wrong with either the import or export of display pages. Let's see what the developers find. 

+1

There is an issue with the export that exludes the DM1 out container. When opening the exported file you will notice that the DM1 out node of the project explorer is empty. There should be one sub node for each master module. This is why the simulator crashes and you get a warning in IQANdesign.


We will solve this in the upcoming 5.03 version of IQANdesign which is planned within the next week.