+2

Help: Directional pulse count losing memory position when pushing a new program.

C. Harp 1 year ago in IQANdesign updated by Gustav Widén (System support) 1 year ago 4

I have a program that uses a directional pulse count channel. I have sent the program with all of the boxes UNchecked for send get options but it still resets the channel. Can anyone offer insight on what the proper settings should be that will retain the accumulated position when you load the program so that it doesn't reset to 0. I am sure that there is small that i am missing, but i need some help with it. 


Here are my current settings:


Send/Get OPTION SETTINGS: (I have attempted sending with all of these unchecked but still get the same result)


Directional pulse count channel: (the IDC does not fire until a button is pressed on a remote screen which is inbound from a canbus display. 






The DPCNT is of type "stored" (see IQANdesign user manual, the section on adjust groups), so leaving the box for stored unchecked means the value will be kept. 


Have you compared the two versions of the project file and ensured that the component ID is the same on the DPCNT?  You see it when bringing up the component navigator (Ctrl-J) 

If you have re-organized the function groups by copy pasting the channel, it will have a new component ID.

There is another possible explanation for the symptom described here. 


In earlier versions up to version 4,  there was an obscure issue that could make a DPCNT located on an expansion reset to zero if the expansion was disabled. See 5.00 release notes case 37868 

Sending a project with the expansion in No contact status had the same effect. 


The printscreen of the send options indicate IQANdesign 5 is used for sending, and the expansion module disable issue was fixed in 5.00. 

But if the master module contains 4.x or older, sending from 5.x does not help; it is not until the master is on 5.00 that this fix is effective. 


Thank you for the feedback. Both the modules have 5.03 firmware flashed into them when the overwrite issue is occurring. All modules were online and showed to have contact during the upload of the program that caused this over wright issue. 

Did you also check that the component ID was the same in the two applications?