0
Fixed

unable to update/download project with MD4 ethernet connection

David Dufour 4 years ago in IQANdesign • updated by Leon Valentin Novac 4 years ago 26
Hi,

I'm actually try to send my project to multiple master configuration.

I have this configuration :

Enclosure 1
MC3 (0) + MD4 (1)

Enclosure 2
MD4 (2) + MD4 (3)

Enclosure 3
MD4 (4) + MD4 (5)

Enclosure 4
MD4 (6) + MD4 (7)

I set the can bus A as Diag network, can bus B as master bus.

Also, I have 4 XA2 connected on the can bus C on the MC3 unit.

I used all node tag without termination.

when I have a success (I need to power down 2 or 4 MD4 to be able to transfer the program),
I got MD4 with version number on the right bottom of the screen.


there is a limitation of the number of equipment who can be updated over the ethernet connection of a MD4 ? is the Can bus adapter will be safer and more stable ?

Also, I tried to transfer the program with all MD4 on the project and I always have the same issues.

Once time I got 2 MD4 with the normal startup page but without communication with the MC3.

Any idea ?

Regards,

David
GOOD, I'M SATISFIED
Great support. I hope all department of Parker work like this.

David
Satisfaction mark by David Dufour 4 years ago
I forgot,

I got very often : "NO REPLY FROM MASTER MODULE"
or unable to initialise communication.

if I power up all enclosure, I'm unable to see anything else than the MD4 I'm connected actually. If I power down only one enclosure, no matter which one, I see other equipments. Really strange.

Best way to avoid this is to power cycle the system.

David
Update.

I actually modified the wiring connection to use a twisted pair cable, no matter the distance. I'm at 3 meters between main panel and all 3 remote enclosure.

Also, I tried to deactivate the internal termination of the network and connect all with daisy chain network with external 120 ohms resistors on each end.

I'm currently able to transfer the program and run it if I limit the diag and master network to the main panel with 1 MD4 & 1 MC3 + 1 remote station with 2 MD4.

All I/O are monitored with a XA2 extension and on a separated network bus.

As before, if I try to update all equipment on the network, I got the same error. I need to update them separately.

Also, if I try to connect an additional MD4 on the network after I updated all of them, the network freeze.

Is anyone have an idea on how I can fix this ?

Regards,

David

P.S. Is it possible to use a star network if enclosure can't be connected in series?
Hi Ulrik, I'm running the version 3.18.9.3947

I made some additional test today to see if I can find something wrong.

There is what I tried today :

Use a new adapter from kvaser (leaf V2) to test the diagnostic bus.

Always with a resistor (120ohms) on both end of the network, I tried to update/communicate with all master on the network.
All masters have termination OFF.

I was able to talk with every equipment if I remove power on some of them, it's a random number. The best success I got is when I was able to talk/update all remote MD4 with the main enclosure powered off. But it's not constant, now I'm unable to do this.

I didn't remove/add any cable or modify anything and I can see all of them, but not in same time.

I have 50 ohms on the CAN_H and CAN_L.
if I check between 0V/CAN_H and 0V/CAN_L I have 2.4V when MC3 is powered down and 2.6V when it's powered.

I have a distance of 6-7 meters between the start to the end of the wiring for the network.

My first impresion is about a network wiring issue, but I can figure why I'm able to talk with each equipment without removing it.

I don't have any high voltage / noisy equipment around.

It's connected to a diesel engine, but when I communicate, it's powered off and no ignition on it.
Also, I run on large battery (12V) and they are full.

I hope it will help you to figure how it is configured.

Regards,

David




Hello David
Based on what you descibred it looks like a problem in the CAN wiring. below som things to check where it might go wrong by experience :
You have multiple cabinets, check all modules use same ground connection,
Do you use twisted pair wiring/cables for the CAN connection
Check CAN_H and CAN_L connections (not twisted by mistake?)
Do you use the ID tags with or without "T" (may double up when installing 120 Ohm separetely in CAN lines)
Try to start with only basisc system, one cabinet with Headmaster, when that runs start adding module by module so you can identify where it geos wrong

Succes
Jos

I
Hi Jos,

I'm agree with you about this. All seem to comes from the wiring or something wrong on my side.

The wiring is color coded and I take time to double check each time I change the wire (I tried multiple type of cable. twisted, not twisted, shielded, Cat5e ethernet cable... yes I tried this!).

For the ID Tags, I only use without "T" actually to avoid any unwanted termination. As it's easy for me to add resistor on the terminal block in the start/end enclosure. All connection are daisy chained between enclosure, no star connection. Connector are the Parker 2.5m with Deutsch build by them connected to industrial terminal block used usually in industrial enclosure. I checked if there is anything wrong with the pinout, it seem to be correct.

Also, I made tests with 1 enclosure and it run correctly. The problems begins when I add other equipments. no matter in which order, so I'm not able to isolate one specific enclosure at this time.

Yesterday, I was able to communication with all master in same time for a short period of time and I transfer the program to each of them without any issues. I was never able to repeat this after this.

Another point, when I try to update the program, iQan design show me the available masters after a short scan if it can see everyone. Master available are random, it's not always the sames. I can see 2-3-4 of them and not always the sames.
I just need to turn the power, don't need to disconnect master to make the system more stable. It's why I can't figure how my wiring is wrong.

Also, is it normal to have 2.4V on the bus and 0V with all MD4 online and when I turn on the MC3, I go to 2.6V?

Currently I have all master with the same program in. If I communicate (yes it works at this moment, but really limit for the stability), I don't see traffic on the master bus. Only on the diagnostic bus when I connect my adapter (kvaser).
The current load of the diagnostic bus in operation run between 4 to 15%.

I hope it will help you to figure where I'm wrong.

Regards,

David
Another thought:
What is the bus utilisation on the master bus? You have alot of master modules.
Nick
Hi Nick,

yesterday I tried to monitor the master bus without any success. I'm able to see traffic on the diagnostic bus, but nothing on the master itself. I use a kvaser adapter and tried with the parker analyser and the kvaser canking software.

On the diagnostic, I have around 4 to 15% traffic (burst).

But I can't figure why the bus doesn't allow me to transfer the program, I can understand when all master are online, but normally when I transfer, it's one master at time.

Also, I was able by a miracle to make all of them to work yesterday. when I tried to show logs from the master (lots of error or message in this logs) all master lost communication for a short period.

After that I continue to run the system and I see random disconnection of masters (MD4).

I can't understand why I didn't see any traffic on the master bus.

Regards,

David
Hello David
It looks like the problem is in the masterbus connection, as you were able to download the application in the multimaster system (over diagnostic bus) ,and with analyser on, nothing is happening on masterbus, correct?
When you connect more MD4's on masterbus of MC3 then the voltage drops to 0 volt?, is looks like you have somewhere a short circuit in CAN bus wiring? Also be sure to have all modules connected to same ground.
Suggest to try connecting CAN masterbus wiring of MD4 masters one by one to the MC3 (headmaster? ) to define where problem lies

Regards, Jos


Hi David,

I agree with Jos. It sounds as though you may have some sort ground float issue.

Some things to try:

-Ensure you have a common 24V and 0V rail for the whole system.
-If this is not possible then you may have to opto isolate the CAN connections.
-You could try and connect up a temporary external CAN harness that runs outside of your panel wiring to prove out your point to point connectivity.

Nick

Hi Nick,

Actually I run on a single pack of 3 large batteries. (200Ah each). I can confirm that I have same source/common to each enclosure and masters.

About the harness, I'll try temporary connection to see if I can find something wrong.

Thanks for the idea.

David
More information to help technical support.

Actually, I found a way to be able to communicate with all masters on same network.

First of all, I change again the cable with Phoenix Canopen cable, twisted pair, each pair shielded individually, grounded from the main enclosure only. Ground connection between enclosure with ungrounded terminal block.

There is what I do to obtain this.

I switch the diagnostic AND master bus on the CAN-B port on all masters and leave the CAN-A port free, it's unassigned in iQanDesign.

After that, I made a try on the CAN-B port with my adapter, no more success. Always random masters available, unable to complete transfer, etc e etc.

But, the communication work, and I'm able to use all master in same time.
I always have the issues that if I try to view a master logs, like the MC3 with large list, I lost the communication on all MD4 for 2-3 seconds. it's not critical as it's only viewing.

After that, I make a test with the CAN-A port to try to transfer the program in all master in same time. and it was a complete success! I try this 5 times in a row, always a success.

After that, I leave a call to Parker Canada at Milton and they suggest to delete 4 masters to go with only the first 4 on the project. I was able to communicate and transfer the project over the CAN-B (Diag/Master port) without any issue. if I go back to 8 masters, it fail. No wiring modification between theses tests, all 8 masters are connected, but unpowered for the last 4.


In fact, I can confirm that it's not the cable, termination who create my issue. It seem the be a real bug from the firmware or internal driver of MD4 or MC3 unit. I'm able to transfer the program to any master, without any wiring modification, unless I keep master to 4 or less. I tried to leave power on all of them and it work.


Is any of you have tried more than 4 masters with MD4/MC3 units actually ?


Thanks,

David
Hi David,

About the question of number of master modules in a system, the largest system we have connected in a single system here in Mölnlycke right now is with 7 masters, but that is built up will a variety of mast module types.
The problems look somewhat similar to an earlier issues we thought we solved in 3.15, problems finding all master modules when using routing (case 22852). One thought I had is that if you started out with some of the modules loaded with versions <3.15, then the previous issue with finding all master modules would still be there. As soon as the individual masters are updated to 3.15 or higher, that should no longer be a problem.

One of the experiences we have from testing a high number of master modules is that the way the termination is done becomes very important.
The way you have done it by setting all master modules to terminate=No, and using external 120 ohm resistors is a good solution. If the internal teriminations that is controlled by the IQANdesign application software is used, then it is easier to end up with a system that is either over terminated or under terminated.
FYI, there was some discussion about the IdTags, it could be good to know that the IQAN master modules ignore the "T" on IdTags, only expansion modules use that. The terminations on master modules are controlled per bus with the properties in IQANdesign.

We'll wire up a system with 7 MD4:s and one MC3 here and try to see if we can reproduce the problems you are seeing.
Hi Gustav,

Thanks for this information.

I'll wait for your results to see if you expect the same issue than me on this.

Did you need anything I need to provide you to execute this test?

Also, it's interesting to know the hint about the idtags. Is is a good practice to keep standard tags and add external resistor on the circuit to avoid confusion ?

Regards,

David
Started
Hi Dave,
When connecting 7 MD4.s and an MC3 in a system here, we were able to reproduce the issue you saw, and we figured out what caused it also. We should be able to get a fix for it for the 3.19 release.

About the recommendation for IdTags, yes, I would agree that it makes sense to use standard IdTags instead of the IdTags with the "T" denominator for master modules, but both works exactly the same.
Great news!

Thanks a lot to execute this test to find the issue.

About the 3.19 update, do you have an idea when it could be released ?

Regards,

David
Hi Ulrik,

Thanks for this information and I'm a bit nervous to send our equipment to the customer.

They comes to get it this Thursday.
There is a pre-release or something I can test to see if the communication will be functional on site ?

If possible, we want to complete this update/testing at our shop to avoid surprise on-site.

Regards,

David


It will be really great!

Thanks,

David
any news about the beta ?

David
Hi David, I will contact you about this beta.
great news! Actually, I'm able to transfer and update from Ethernet and also with Canbus network without issues.

Thanks everyone for this support.

I just need to wait for the official release !

Hi Ulrik,

Any news about the official release 3.19 of the software?


David
Will be available within an hour, if nothing bad happens... :-)

Hi all, I`m using a Kvaser Leaf Light HS, if anyone could help me I`m trying to send .tmr files over x-analyser version 2.97 but it is demo version, does anyone have an alternative for this software who also got his features of cycling and bit rate options, etc. or is it possible for someone to share it as a standard version ?

Thank you