0
Answered

Error, stopped critical

Giel Coopman 1 month ago in IQANdesign • updated by Thomas Moberg (System support) 1 month ago 5

In a new controller we tried to load a program, but did not succeed completely. Then the LED of the controller blinks 4 times red and 1 time yellow followed by 17 times yellow. And when we try again to connect, the master module can no longer be found. Is there something we can do?

Hello.

Try starting the unit with the Bypass application (page 85 in instruction book).

You do this by either shorting the address tag pins when starting or start without anything connected to these pins.

Thanks, we have a connection again!

Our program contains a cycle recording for 12 outputs, this cycle must be played afterwards. The problem is that we used more memory than available. Is there a way to expand the RAM memory off the controller or is there another controller with more RAM that we can use?


+1

Hello.


I guessing that you are using big arrays to do this.

Using big arrays take a lot of RAM, and if you try to store them you will run out of setting memory also (that is where it will be stored).

From what i can tell you are using a MC43 and a MD4.

And no, you can not get any more RAM on the MC43.

But if you look at the MD4 we do not say anything about the RAM for that one, but in the data sheet we say that the RAM is 256 MB. so if you want to have big arrays you can use the MD4 for that. But you will run in to problems if you try to store the array because the MD4 does not have any more settings memory that the MC4x.

Yes indeed, I have reduced the size of the arrays to our minimun and the memory problem is solved.

Thanks for the support!!