0
Under review

IQAN Design 5 'start measure' via Ethernet not showing all channels

Frank GUO 3 months ago in IQANdesign • updated by Gustav Widén (System support) 3 weeks ago 14

We are using IQAN Design 5.04.8.5179, connecting MC43 via Ethernet.

When we connecting via Ethernet, start measure function does not show all channel status. Most of channels stay in grey color, and not showing its status.

It happens when the number of channels are too many. When only few channels in that group, the status will show. So, it looks like the data are not communicated between IQAN Design and the master module (MC43). Or data were overflow when too many channels showing at the same time.

How many channels do you have in the function groups where you see the problem? 

A quick way to check is to just press Ctrl-A, the hint to the right will show the component count for the function group. 

For example, the function group with 114 components is having problems.

Thanks, that seems like a pretty normal number of components in a function group. 

What cycle time are you running on the MC43? 

What's your cycle utilization?

Cycle time 20ms

Cycle utilization 67.29%

Memory utilization 90.50%

The cycle utilization at this cycle time looks fine, that cannot be the issue. 

Although the memory utilization is quite high, it shouldn't be a problem for the communication. 


A really basic question, do you have the exact same project file version in the MC4x and IQANdesign? In a situation where you have some new channels in the project in IQANdesign that is missing in the master module, you will see those missing channel as gray (as long as there are enough channels that do match). 


That was using same program for sure.

Haven't been able to reproduce anything like this. But I looked at the original post again and saw that it said: 

"Most of channels stay in grey color, and not showing its status."



Actually, they gray box is an indication of a status also. 


The gray box can indicate any of the following statuses:

-unknown

-not evaluated

-disabled


To see the full status, either hover with the mouse over the channel to bring up the tool-tip hint, or drag the channel to the "multimeter" measure window:


Unknown would be what you would for example see if there are different versions of the project file in IQANdesign and in the master, and the project file open in IQANdesign contain channels that aren't in the version of the project file that was sent to the master. 

Not evaluated is for channels that haven't been calculated yet. For example, incoming CAN frames that haven't yet been recieved. 

Disabled is for channels that are on a disabled expansion or in a disabled function group. 

Hi Gustav,

All channels mentioned were alive channels, and can be measured if CAN is selected as communication method. The problem only happened when using Ethernet to measure or monitor channels.

Regards,

Frank

We also get problems sometimes when viewing a function group with 677 components. We find that we get greyed box and unable to 'measure' anything on screen using a computer, could this also be similar issue?

Kevin,

For the size of function group you have with 677 components, I am suspecting that you might be hitting the limit for number of items you can stream a measurement on at the same time. Do you get the "measure terminated" dialog?


The limit is 999 items, but I just realized the component count you see in the lower right corner will only count function groups as one component. 

One idea to try is to reduce the maximum update rate of the measurement. This can be done in Tools > Options > Measure > Max udpate rate. For short cycle times over ethernet there will be a lot of data. Maybe the user interface does not manage to update fast enough.

by changing the update rate did not help.

However, I noticed that the grey channels were only affecting one or two groups, which has bit more And when it is grey, it was showing 'unknown'.

Frank,

Thanks. I think I understand why this happens now.  When you select Ethernet in IQANdesign/IQANrun , it is normally using the  UDP protocol, which has better performance than TCP/IP. But UDP has the drawback that packages can be lost, especially when there is lots of traffic on the network. Normally this is not an issue, it is handled by the higher-layer protocols between IQANdesign/IQANrun and the master, but I think you have come across a gap here, when starting a large measurement on many components. 

There is a workaround, by using the tab "Static modules" instead of "Discovered modules", you can force IQANdesign/IQANrun to use TCP/IP. I believe this should solve the issue you are having. 

To use this workaround, you'd need to write down the IP address of the MD4, switch it off so that it doesn't show up under discovered modules, enter the IP address under "Static modules", start the module (hoping that it gets the same IP address), and then connect.