0

Multi-master system mismatch

Michael Carlyle 11 months ago in IQANdesign updated by Gustav Widén (System support) 10 months ago 2

We have a machine here with 3 MC43's and an MD4 - the program seems to load in all the modules fine but on startup MC43-1 is showing offline (like it's started in safe mode maybe?).  We checked the address (ID) tag and it seems to have the correct resistance but when we measure Add_L_voltage - it is reading 3.58 V which seems to be above the 3 V that would put it into safe mode and we get the system mismatch error (3 red flashes followed by 3 yellow.  We have tried 3 modules with the same result (the program was loaded in by Ethernet and by canbus with the same results).

Any ideas as to where/what to check that would cause this voltage to be reading high (assuming that is the problem)?

FYI - when I pull the program from the system (Get Project) the MC43-1 program gets pulled along with the others which makes me think it is in safe mode.

From the manual:

"Safe mode
This is a special start-up mode that is used for master modules and puts the unit in a
safe state without starting any application. You may bypass loading the application in
the MC4x on start up (enter safe mode) in two ways.
1 If the ADDR_L voltage > 3.00V (ADDR_L pin shorted to ADDR_H) is detected
when the module starts (during power up) the application will not be loaded. When safe
mode is desired, a jumper is put across pins 4 and 20 on the C1 connector, in place of
an ID-Tag.
2 The MC4x will also start in safe mode if the ID-Tag is absent. This is an easier
method since you can just remove 1 wire of the ID-Tag "


Update - the module does not go into safe mode at 3V.  We read the same voltage on the low side of the address tag (was actually 3.86V) in a functioning machine.  It will go into safe mode if it is shorted across (5V).

The problem was a camera system back-feeding voltage into a digital output (wired incorrectly).

Thanks Michael. As you figured, the specific voltage on ADDR_L that causes the MC4x to bypass its application isn't 3 V (it's a copy paste error from another master). 

If the module would have had the application bypassed, it would have blinked "application not loaded", 1 long yellow followed by 1 short yellow. 

I am confused by the problem description and the resolution. 

The system mismatch blink (3:3)  would come if the MC4 doesn't have the exact same version of the project as the other masters. It would make sense if that module was offline when the rest of the system was updated.

For a reverse-feed, I would have expected to see 4:2:1:1:1 (4 red and 2 yellow, followed 1 yellow 3 times) 

If the MC43 didn't start its application due to reverse feed, then I would have expected that there should have been a "no reply" dialog during sending.