Problem updating Firmware (via CAN)

Rick 3 years ago in IQANdesign updated by Gustav Widén (System support) 5 months ago 2

Last weeks, we are having issues updating MC41 modules via USB-CAN (and some of our service guys told having the same issues with a MC42, but that is unconfirmed). It seems the  "Updating Firmware" step takes forever. Eventually we succeeded with one laptop, but it took ~20 minutes, where it would normally take 1 or 2 minutes at most.

Other attempts would result in a "No reply from master module" failure. And what seems to be strange: we tried to upload with IQAN 5.03 but the failure message said it failed uploading Firmware version 6.00.48. So we tried again with IQAN 6.00.48, and the upload was done within a flash... But strange enough, I couldn't upload the same (IQAN Design 6.00.48) program earlier on another MC41. It would also get stuck at the Update Firmware part, and then the older 5.03 version would upload the program without problems...

So we have this issue with both IQAN Design 5.03 and 6.00.48. Tried several laptops, but that didn't make a difference either.  Using the same KVaser LEAF Light cable as always.

The strange thing is, we have been using IQAN Design 5.03 and 6.00.48 for quite a long time, without having issues. It recently started. To me, it sounds as if something changed on the hardware, or maybe some Windows (10) update is causing trouble.

I think the reason for the dialog box that seemed strange is that is that some error dialog in IQANrun/IQANdesign will show the module, address and firmware version of the module you are connected to.  

For example if you loose the connection: 

What you describe seems very similar to an issue I came across about 3-4 years ago. That was an MC31 update that took 25 minutes, and the versions were 4.05 and 4.06. Couldn't reproduce it consistently though.

It might just be a coincidence, but that was also with a Kvaser Leaf (not sure about the driver version)


Found a problem with our interface to the Kvaser, will be fixed.