0

Issue reading CAN message

Kerry Brock 8 months ago in IQANdesign 0

I have an issue where there are four identical sensors on CAN-D of a MC43.  It has worked without any problems for about a year.  Currently, we are constantly seeing a "Timeout" for all of the sensors on this bus.  There are no other devices on the bus except the four sensors and the MC43.  If we use IQANanalyze, we can see the information from the sensors on the bus, but again, the MC43 shows a timeout for all the sensor JFIN channels.  If we physically unplug the harness from the MC43 and connect it to a MC43 in test box, the MC43 will recognize the sensor CAN frames.  We tried swapping out the original MC43 with the test box MC43 and re-programmed to the machine project file and the test box MC43 does not recognize the sensor CAN frames.  We have an identical setup on CAN-C using the same type of sensors and do not have an issue with reading those CAN frames.  We are using IQANdesign 5.07 and it is in a system with 2-MD4's, 2-MC43's and 1-MC43-FS.  What may be causing this issue?