0

Problem updating MD4 with IQANgo through iphone 12 Pro Max

Pierre Fagrell 3 months ago in IQANgo updated 3 months ago 4

I tried to upgrade a system with iqan connect from my computer with IQANdesign with IQAN connect to an iphone connected with G11.

The machine has MD4 and MC43 and XC21.

The MC43 has some CANopen inverters on a second CAN bus.

Iphone software version is 15.6.1

IQANgo version 6.08.22

The old firmware was 6.05.19.2782. While upgrading to 6.08 IQANdesign lost connection after a few minutes. Trying again many times always disconnects. Also with IQAN run through IQAN connect it disconnects.

Then we tried sending the file directly from IQANgo and exactly the same problem happens again and again. The MD4 disconnects at "Progress 11".

Image 3278

Then we connected with IQAN run through bluetooth on a laptop. The ugprade worked right away and went through on the first try.

It is hard to know what this could be, but it looks like the updates stop at a very early stage. 


What version of firmware did you have in the G11? 

(a G11 updated to the version provided in IQANgo 6.08 has 1.12) 

Any other nodes on the Diagnostics bus?

Unfortunately I do not know which firmware is in the G11, but it was not updated at this time and the iPhone app did not give any prompts to update, Is it stored in the clone file or some logfile in IQANgo or IQANrun?

I will try to find out in a few weeks if I get access to the machine. (and for future bug reports)

The diagnostic bus only has 1 MD4, 1 MC43FS, 1 G11. It is also used as a master bus between them.

Thank you, if IQANgo 6.08 did not give a prompt to update, then the G11 firmware should already have been at 1.12.

I just verified with the customer and he is sure the app did not ask for any updates.

In the app it says:

IQANgo 6.08.22

G11 1.12.2.17