+1
Fixed

Issues with system reboot after remote update using 7.0.1

Anders Olsson 5 months ago in IQANrun updated by Gustav Widén (System support) 2 months ago 8
GOOD, I'M SATISFIED
Satisfaction mark by Anders Olsson 2 months ago

Sorry, I have issues posting, the automatic header topic search hides the post button for me.

Anyway, when I try to do remote software update using IQANrun 7.0.1 on a system with G12+MC42+MC43+MD4 the system hangs when it is rebooting.

I am connecting trough an Android phone and I can update the system locally from the phone without a problem, so ut seems related to the internet link or IQANrun.

If I disconnect the remote assistance on the phone when the system has the blue screen and connect again, the system will reboot as soon as the link is active again.

if I turn off the system with the blue screen and turn it on again it boots up and runs normally, but I then have difficulties connecting to it again using Bluetooth.

If I manage to connect, the system reboots as soon as the link is active, even if the system was running normally before.

IQANrun hangs at the machine system reboot and doesn't respond independent of what I do on the machine side and I have to kill and restart IQANrun to be able to use it.

Image 4086

Image 4085

Is the IQANgo app up-to-date?

What IQANdesign version are you using for the project? 

Did you have this when updating firmware in the IQAN system? When updating e.g. from 7.00 to 7.01, each master will take longer to finish updating. 

Any chance you could get information about the LED blink code shown on the MC43 and MC42 in the system?

I am using IQANgo 7.01.5, IQANdesign 7.01.18 and IQANrun 7.01.6.


I have tried updating both from 7.0 -> 7.01 and within the same version.

I have also tried both android and Iphone at the machine side.

To rule out any network issues, I also tested updating in another location.


The result is the same every time: The machine computers get stuck at reboot as in my previous post.

If I exit IQANgo at the machine side and reconnect using remote assistance again, the machine computers finishes the reboot as soon as the link is active, as long as the PC running IQANrun is still active.

If I would kill IQANrun on the PC before I do the reconnect using remote assistance on the machine side, then it will not continue the reboot.

Whatever I do, IQANrun remains frozen all through the process and I have to kill it eventually.

As I mentioned before, updating locally with the file on the phone works perfectly, so it is something with the reboot when updating through internet.

Unfortunately the computers are mounted in a way that it is difficult to see the LEDs, so i didn't analyze those yet.

Update:


I tested again today with a fresh set of components in our test bench setup.

The IQANRun computer was located in the same room as the test setup, but connected over internet to the bluetooth adapter.

The modules were pre-loaded though Ethernet and i then tried uploading the same application again over internet.


It stops at the exact same point this time.

Both the MC42 and the MC43 modules are flashing one long, three short yellow, meaning "Waiting for Reboot"


I can make the computers reboot by disconnecting the phone from the system and connecting it again, so it works at the machine side then, but IQANRun doesn't fully complete the reboot process but hangs.

Started

We found the problem in 7.01. 

A fix will be released in IQANdesign 7.02.

Any idea when 7.02 is being released?  This is starting to cause some real issues.

+1
Fixed

Fixed by updating system to 7.02, released today.