+1
Planned

PIN Code Dialog not showing in 7.01

Daniel Small 2 months ago in IQANdesign updated by Gustav Widén (System support) 3 weeks ago 9

I am trying to use a PIN code in a new project using IQAN design 7.01 to place some settings behind a PIN.

I have a single object VDIN in "showing" for the default function of the PIN code.  I am not using a state machine as a function selector for the PIN code.  I tested both a physical MD-4 and IQAN Simulate.  When I press the VDIN button, I can see the VDIN go to true but no PIN dialog pops up.

I duplicated the project in 6.08 and the PIN dialog works fine.  

I ran "compare with" between the two programs and the only differences are the project ID, checksums, last change and the passwords and pin show up as dots on the project you are comparing too.  But the meat of the project is identical.

Am I doing something wrong or is this a bug?

I have the same problem. Have to  rollback to 7.00 this morning to help our client, because they couldn't enter the pincode.

+1

I have the same problem.

Solution is to add title to the PIN Code chanel. When you add title the dialogue is shown.

This is a problem because in previous versions you could use this channel without a title, and it worked fine.

+1

Thanks Jesus for this solution!

Thanks Jesus, but is still a bug in my optinion.
We have to be care that our guys not update there IQAN software (7.01) together with older software files.

Hard to control since we have more international locations!

Thank for bringing this to our attention.

I did some testing myself and found that you need to have at least 3 characters in the header for the dialog to show up.

We will be looking in to this.

3 characters in what header?

The Header property on the PCC channel

Image 4130