iQan Simulate MD4 bug

David Dufour 8 years ago in IQANsimulate updated by Ulrik Zakariasson (Software development) 8 years ago 13

I just updated to the Version and I'm unable now to see the start page on the screen. The only thing I have is the version number on the bottom right of the panel.

It work with a MD3 program.

To do the test, I use the demo program from Parker.

The MD3 demos work correctly, but all MD4 demos won't.

Satisfaction mark by David Dufour 8 years ago

I had this problem as well...I had to rotate the startup/splash screen to the left 90° to get it to show up.


Interesting, but I can't see the main page of the MD4. You mean I need to place a startup image to be able to see the main page ?

There is what I can see after starting the simulator. it's the demo from parker.

I also tried to use an old project who is known to work actually, and I got the same issue.


An idea you could try is to add an exception to your firewall in windows for IQANsimulate. The simulator uses TCP and UDP communication for some of its internal functions. Depending on which firewall that is used in windows it may be blocked.

Hi Anders,

it's a good idea. I tried it, but without success.

The firewall was already turned off, but the public on. I tried to turn off all of them, without any changes on the bugs.

Maybe, it could be an internal bug?

I'll try to uninstall and reinstall the application in case I have a corrupted installation.


Just to add additional information, I did a full uninstall and directory delete of the 3.x and 4.x version of iQan software.

After that, I rebooted and reinstalled all of them.

Same thing. and now I got a very strange issue with an existing and currently working project (3.19.x version).

Most of the MD4 appear normally, but I still have two with version with the 4.2.5.xx update.

I tried with a virtual PC without any previous version to reinstall off of this and everything works. So I can presume it's an incompatibility somewhere.

Any idea of what it can be ? I need to do a presentation/training of a new customer tomorrow, and now I don't have a working computer to do that.

Check the screenshot to see my last test.


I forgot to mention that the 3.19.x version is also non-working too now. If I open the same project (saved in 3.19.x) with 3.19.x simulator, I have the same issue. It's look like it's the "simulator hardware" who have a bug...

it's definitively my compute who have an issue with this, but I can't find where.


It could be that some other program on your computer is using a TCP port that the simulator is trying to use. To determine this, you could run the following command in a windows command prompt (cmd):

netstat -ab > ports.txt

This will create a file called ports.txt in the current folder. Please submit this file to iqanbugreport@parker.com.

I sent the email with the ports list. I hope it will help you to figure out what kind of issue I have.



From the list of ports used by other programs I could see a conflict with IQANsimulate. The TCP ports used by IQANsimulate are in the range 27020 - 27068 depending on module type and addresses. If any other program uses the same port the communication between the real-time simulation and the GUI simulation will fail.

Currently the other programs using these ports needs to be reconfigured or closed while simulating. Another option might also be to change the address of the master while simulating.

A more long term solution will most likely be implemented in an upcoming IQANsimulate version to avoid these conflicts.

Great! finally you found the guilty software.

While this version is in development, I have an option to make it work.