0

usb connection problem with IQAN Run2

bk_hitech 3 years ago in IQANrun • updated by Gustav Widén (System support) 3 years ago 2

The Equipment I work on uses both the MD3 or a MC2 module in our models and as a field tech I need to sometimes either update software due to changes or replace modules. 75% of the time when I try to connect to the modules using My USB cable it will not connect to the master module. I then go thru the ritual of crossing my fingers, rubbing My lucky rabbits foot and restarting My laptop, powering equipment down and up holding My right foot of the ground and then possibly it will connect. I have been told this is an issue with USB III ports on our Dell laptops as We did not have this issue with our previous laptops and we do not have this issue with our small tablets We use. Has anyone else run into this? If it is due to the USB III is there a driver patch or something?This issue is not isolated to one machine. I have never tried connecting on the CAN side if there is no fix for the USB is that possible to use for programming? Thanks

Never mind, I tried the CAN communication method versus the USB and it worked flawless. Appears the CAN communication is much more stable.

BK

It looks like you already answered your own question. Yes, using CAN instead of a direct USB connection is by far the best solution for getting a reliable connection.

Over the years of using USB, there has been loads of different problems with the stability of the USB connections, and we have made upgrades on the MC2 and MD3 software, the PC tools and the USB drivers installing with the PC tools.

One of the latest changes to try to get the USB more robust was to redesign the hardware using a USB components for the MD3-M15 and MC2-M14. This seems to have helped some, but my recommendation would be to always carry one of the USB-CAN dongles that work with IQAN:

http://forum.iqan.se/topics/231-usb-to-can-interfaces/