0
Fixed

IQAN Run Application Mismatch

Meric Forest 3 years ago in IQANrun updated by Gustav Widén (System support) 3 years ago 8

Trying to retrieve clone file from machine but keep getting error for application mismatch. The error is described as " No corresponding application exist for the firmware being loaded " .The ida file in the machine is fully updated to the newest version along with our IQAN Run. Any thoughts? Thank you!


GOOD, I'M SATISFIED

Thanks a lot!

Satisfaction mark by Meric Forest 3 years ago

Hello Meric.


From the message it sounds like the application and the firmware does not match.

But that should not be something you can do as the firmware is updated together with the application if the firmware in the master is another version when you download.


Got some questions to help us figure out what is wrong here.

What Master module are you are using?

Is the application running OK in the master or does it not work?

Can you download to the master without problem?

What is your communication interface, USB, CAN or ethernet?


Hi Thomas!


The Master module that we are using is the MD4. The application downloaded to our MD4 is working fine. Our machine is working great. Therefore we can download to the master without any problems. The communication interface is ethernet.


A couple extra notes for you: In IQAN Run while connected to our master module we do get the online connection. Therefore we can view project, get the settings and we can also send the ida file through IQAN Run. The only thing we cant do is retrieve the clone file.


Thank you!

+1

I think that I found the reason for your problem. To improve performance when getting a clone IQANrun stores some resources in a cache. For example your cache may contain an exact copy of the images of the MD4. The problem is that the module address is not checked when determining if the cache version can be used. So when IQANrun is assembling the clone file it discovers that the module address of the image data differs and displays an error message that is bit cryptic.


You should be able to resolve this by clearing the cache. Empty the folder "C:\ProgramData\IQANrun 4\Firmware Cache" and try getting the clone again.


Hi guys!


We tried resolving this by clearing the cache however the address mismatch issue is still appearing. Any other suggestions?

Under review

I ran into a really obscure bug last week that has this exact same symptom; when getting clone from an IQAN-MD4 there was the dialog with error message "No corresponding application exist for the firmware being loaded"


We figured out that this can happen if one is replacing the application in an MD4 with another application that has a different address, and where none of these two MD4 applications have pdf files that are used on the display pages.

When sending an application to the MD4, only firmware resources that have been changed are updated. But here an unused file for pdf was left unchanged, and this was then only discovered when getting the clone.


There will be a solution for this problem in version 4.07.

In the meantime, a workaround (assuming that this is also the problem you have) is to use IQANdesign to modify the project file by adding a pdf and use this on a page, send this modified file to the MD4, and then finally send the original file again.



Thank you Gustav, your workaround resolved our problem!

Fixed

Thanks Gary, I had already forgotten about this one.


The problem was solved in IQANdesign 4.07.