0
Answered

autoip connection

blags 4 years ago in IQANdesign updated by Ulrik Zakariasson (Software development) 4 years ago 5

For some reason the MD4 is not discovered, but this should not be a problem, I have the IP address. But I cannot enter a static IP address in the 169.254.nnn.nnn range I get warned that only addresses in the 10.0.0.0 to nnn or 172.16.0.0 to nnn or 192.168.0.0 to nnn

Answered

Auto IP is used when there is no DHCP server in the network, e.g. when an MD4 is directly connected to the Ethernet port on a PC. You can check that you have an auto IP address on your PC by running the command ipconfig. There should be a 169.254.x.y address on your network card, otherwise you do not have an auto IP address. Note that there can be a delay of 1-2 minutes before you are assigned an auto IP address.

Also, make sure you haven't disabled auto IP in Windows Control Panel. Go to properties for your Ethernet adapter, select properties for IPv4 and tab Alternate Configuration where Automatic private IP address must be checked. (This is for Windows 7, may look different on other versions)

I do have an auto-ip as I mentionned in my original question. I can ping both my own PC and the MD4. ifconfig shows my IP allocated by auto-ip. I can "ping" the MD4 also, I simply cannot use it to connect! I am prompted to use a IP as I mentionned in my original question:

10.0.0.0 to whatever

172.16.0.0 to whatever and

192.169.0.0 to whatever


Auto-IP is in the range 169.254.0.0 to whatever and I am not permitted to use it.


Strange, if both your PC and the MD4 have auto IP addresses and are on the same sub-net, it should turn up in the list on tab Discovered modules.

Static modules are meant for reaching modules that have been assigned a static IP address in the IQANdesign project file. This is typically useful when your modules are located on other sub-nets, e.g. via VPN.

Here are a few questions/things to try:

  1. How are you connected to the MD4 - cable direct from MD4 to Ethernet port on PC or via router?
  2. Do you have a firewall running that blocks UDP traffic? Try to disable the firewall to see if that helps.
  3. Do you use any virtualization software, e.g. VMware? They sometimes add virtual network adapters that can interfere with IQANdesign.

I realize from your response that this issue is related to a previous connection issue I had last year that I have not fully resolved. I can only assume on my end the computer setups here blocks UDP traffic, but disabling the firewall would not be an option for the assembly line. I was hoping I could connect directly computer to MD4, I am not using any virtualization software. My work-around is to use an access point and use the IP address given by the DHCP server. It is not very convenient but it works. I was only wondering why I could not specifically select an IP address offered by auto-ip.

The reason we have excluded the auto IP range from Static modules is that auto IP addresses are not very static, they change often. It could be confusing to allow them.

I'll add a feature request to allow auto IP addresses though.