+1

Start up MD4 and showing start display with delay when language is Japanese

Laura 2 years ago in IQANdesign • updated by Gustav Widén (System support) 5 months ago 13

When an application is loaded/started with a MD4 as master, and the display language is Japanese. After start up the display remains black for 10 seconds. Then the start display appears. When english is the choosen language, there is no time between start up the application and showing the display page. For a user it is as the display of the MD4 is broken when showing the display page is taken so long.

Can somebody tell me if this will be solved soon??

Its due to the font selected for Japanese language. Its quite large and takes time to load during boot.

Take a look at Google Noto Fonts. They have individual font packages for each language.


https://www.google.com/get/noto/

Unfortunately no progress has been made on the matter.

I've opened a new case for it (ref 44491) since I couldn't find one.

What font are you using?

We use Arial Unicode MS

Maybe it is possible to make it more clear that the module is running, but is waiting for the language by showing the start up image longer until the font is also loaded.

We are having trouble with the same issue. At the very least, it would be helpful if the screen was not blank while the font set is loading.


http://forum.iqan.se/forums/1-software/topics/490-language-issue-md4/


Gustav says the problem is under review, but I don't know if there is a case number.

I tried a Google Noto font, with no improvement in load time. I then changed all the languages to use the Google Noto font, including English, but there is always the 10 second delay when the controller is powered up.

+2

I can clarify the Google Noto Fonts we are using instead of Arial Unicode MS - 22MB.


For English NotoSans-Regular.ttf - 445 KB

For Japanese NotoSansJP-Regular.otf  - 4.33MB

For Simple Chinese NotoSansSC-Regular.otf - 7.98MB

For Korean NotoSansKR-Regular.otf - 4.37MB


Then there are variation from the Regular that might look better in your application.

Look here Noto-CJK


Hope this works out.

Thanks Jonas. I have tried these fonts, and I can confirm that NotoSansJP-Regular and NotoSansSC-Regular loads much faster (about 5 seconds). However NotoSansKR-Regular seems to load, but does not show on the MD4-7 screen.

David, for the font that did not work, did you check if you have the hint for "font lacks characters" in the project check?

I am getting the "Font lacks characters" warning, but only for Chinese (Simplified).

Also with the google noto fonts the display is at startup slof, it takes about 7 seconds to start up. Now we have a MD4-5 and design 5. 

What happens when somebody loads an application and does not have the noto font installed?

The font you select in IQANdesign gets embedded in the project file. As long as the project (or clone) file is sent from IQANrun, it will contain the font. 

But if the file is opened by an IQANdesign user who doesn't have the font and who sends the file, then it is sent without it.