0
Completed

G11 Firmware issue

James A 1 year ago in Gateways / G11 updated 11 months ago 14

I am having issues with the G11 v1.09 firmware.   Today I tried using my android phone (Pixel 3) I go to update a MD3 with a IQAN v4.07 program file.  Something I have done several times with out issue.  Right away the process files and the G11 blinks a 4,1 RED,Orange error code.  After some troubleshooting I narrowed it down to the G11 firmware.

Luckly I have a few G11 modems in stock as I sometime supply them to our customer with their machine.  The ones in stock came with firmware v1.07.  Some time ago IQANsync was updated and included v1.08.  Using either v1.07 or v1.08 I have had no issues with the G11 modem.  However if I update the G11 to v1.09 it will keep me from using it.

Any ideas on what is going on.  Is it possible to flash it back with v1.08 or v1.07 firmware?

Under review

Only 4 red 1 yellow and then repeating, or do you see additional blinks after the yellow? 

For some types of errors, a longer blink code follows afterwards. This can be hard to count, but if you film it you can send the file here: 

https://iqan.sharefile.com/share/filedrop

What else is on the CAN bus except for the MD3 and G11 ? 


Both IQANsync and IQANrun 6.00 includes the latest G11 firmware, so there is no easy way to roll back to an older firmware. 

Blink code is 4 red, 1 yellow, pause, 1 yellow, pause, 3 yellow, pause, back to 4 red

Each pause is about 1 sec.


Diag bus is attached to J1939 bus which has a MD3, engine, fusebox & G11 if attached.  IQAN program file has 'J1939 start address' set to 177.  Fuse box address is highest otherwise at 176


I did reattempt uploading a file with the engine and fusebox CAN wires disconnected.  This resulted in the same failure with the same blink code.

Thanks. The traffic on the CAN bus tends to be the "usual suspect", but in this case it seems as if the issue could be between the specific Android phone and the G11. 

But so far the guys here have been unable to reproduce.

With the G11 that you have 1.09 on, is it possible for you to make a small bench test with just the MD3, G11 and phone connected? 

Line up the MD3, G11 and Pixel 3 phone running IQANsync next to each other, and film all three when  performing the send operation. 

Send to https://iqan.sharefile.com/share/filedrop


This would provide useful clues to our developers, showing what stage the IQANsync app and the MD3 is in when it goes wrong. 


+1
I have encountered the same issue. My tech was on the road and told me he had an error of 4 red and 1 yellow, which I followed with 1 yellow 3 yellow, which suprised him that I knew what was coming. In my case I only have the G11 on the Diag bus as is shown below. 3 things to note with our issue was that he is using a Samsung Galaxy S10+, our system uses the MD4, and this error did not stop us from remotely monitoring and pushing a new program in when needed. 

Thanks for the added info Mitch,

It sounds strange that you managed to use the G11 when it was in this state, with the G11 blinking 4 red and 1 yellow, it is in a crashed stated. It might perhaps be that the technician who was at the machine got it to work after restarting?

+1

I did some basic test but got caught up with regular work duties.

I made a stripped down program with only the G11 and MD3 in the program and it transferred fine on v1.09

Our main program is quite complex.  I will do addition testing later on next week.

+1

I uploaded to video files for you.  One is a Pixel 3 XL failing to updated and the other is a Samsung Galaxy S10+ failing.

Both have IQANsync V6.00.4 and Android V9.

I did test with a older phone I had, a Samsung Galaxy Edge S7+  with Android V8.  That one successfully used the G11 with  v1.09.

We have experienced the same issue with a G11 where we loaded 1.09 firmware on it.  Tried a couple different Samsung phones and could not connect.  In fact, the direct connection on the CAN line via the USB-CAN Kvaser tool would not work while the G11 had this firmware in it.  Once we installed a G11 with older firmware into the sytem, everything worked as it normally had in the past.  We gave our G11 to Ed Polzin hoping he might have some success fixing it...  Hope you guys can sort this one out.

Any updates on this issue?

We've found the issue and have a new firmware that we are currently testing. If all goes well we should be able to release in early December. 

Completed

The 6.01 of the apps are now released, this has a new firmware for the IQAN-G11, version 1.10, that solves the issue in the previous version. 


+1

Updated the app and tested before and after updating the G11 firmware.  I was able to successfully flash the MD3 when using the new firmware.  Looks like v1.10 did the job.  Thanks for you help.