0

Iqan Simulation window invisible

Jean-Marc Zanni 11 months ago in IQANdesign updated by Gustav Widén (System support) 11 months ago 5

I was developing in Iqan 6.01.  Started a simulation.  When the simulation was running, I could not display the simulation page or the simulated screen.  The icon was visible in the taskbar but clicking on it would not display it.  It seems that the window was outside of my screen space.

When I stopped it the simulation page is visible but I cannot stop it/close it.  Here is a

screen shot of my full set-up.  I can see the corner of the simulate screen but whenever I click on it Window Chimes but does not get focus.  Cannot use the Close button.

I have dual 4K screen on top and Full HDMi on bottom

will have to kill the simulate task thru the system manager.

Here is the screen shot when when Simulate runs:

If I click on the Simulate icon, then inside the popup for the window, all my other windows are closing as long as I hold the mouse.

Not sure if related, but when starting the simulation, using a previous simulation file I get an error about missing external function then other warning about not reading all the set-up.

Move the Simulation window during the initialization to top right monitor.  same issue.  Now also have Icon bottom of right monitor which would indicate this is the page the window should be in but nothing will show.  Ran out of space to add this last screen shot..

+1

Try using Alt+Space and then select Move to move the Simulate window when you cannot access it.

Hi Ed,

Tried the Alt+Space. But no luck

Tried to start new simulation just to see, same result.

Tried to uninstall and re-install S6

Starting the simulation as stand alone same result.  It is all OK until I select run.  Then the window disappear.

When starting simulation from within Design, the simulation is active.  I have the data displayed within Design but cannot see the simulated screen or the Simulate window.  When I stop the simulation the window reappear but It is dead.  it does not respond to anything.  I have to use task manager to kill the task.

As you can see it when the simulation is stopped, you should be able to untick the box for "Use different window size when simulating". When this option isn't ticked, the IQANsimulate window will use the same position and size when simulating as that it has when editing. 

Hi Cliff,

Stay on top is set:

The only difference is the "Use different window....".  so I tried it with the option uncheck.  The Simulation window now does not disappear.  It opened on a different window (where it was when I opened Simulate directly rather than thru the Design interface). When Running I can change the value of the different elements and I can move the window.  The simulated screen window however is not visible. When I first stop the simulation the window became dead as it did before and I could not close it.  But after I moved the window in the same window as Design then I was able to close it.  This brought the "Save dialog box".  I have to assume that before the dialog box was probably opening outside the Windows space giving the impression it was dead.

Here is screen shot when simulation is running with the window moved back to the same window as Design:

No signs of the Simulated screen window.  

+1

Did remove the external screen and started simulation on local. now the Simulated screen did show up:

I then  reconnected the external screen.  The window did not move.  Closed and saved.

Restarted and launched simulation thru Design.  Both display and Simulation did reappear where they were saved.

Conclusion:

Found a way out. 

Seems that the widows were opened outside of the actual screen size.  Had no / do not know a way to recenter the windows. 

The taskbar icon option did not have the Full screen option I have used in the past to correct similar issue.

Wondering if the issue was caused by the fact that I have 3 screens with different resolution(2x4K and one Full HD).  or because I use different screen configuration.  For info this is a laptop and when I am on site I use a different set-up with a single external Full HD screen. I am not hundred percent sur but this was the set-up I used last.