0

'Wrong ID Tag' for single module MD3 system

Anthony Le 8 months ago in Master modules / MD3 updated by Gustav Widén (System support) 8 months ago 3

Hello,

Does an MD3 require an ID Tag if it's being used in a single module network? The only other module on the CAN network is a non-IQAN J1939 module (engine ecu.) This is how we communicate with the engine. The machine did not have an ID tag when it was built back in 2010 and we recently replaced the MD3 because the screen was too dark to read. We had some problems opening the original ida file because it was an old beta version. So we had to pull a clone file from the existing MD3 and saved it as an ida3 before sending it to a new replacement MD3. After installing the new MD3 the 'Wrong IdTag!' error appears. I've searched this forum for answers but can't seem to find this particular case. Is there a new address requirement for MD3's that was not the case back in 2010? Did saving the file from ida to ida3 cause this problem?

If you are having problems sending the application to the new MD3, we always have problems sending old applications because the firmware has to be downgraded. What I've done in the past is send a blank IQAN4 project. Then try sending the application you want long term using IQANrun 4 or later.

Thank you for the reply. I forgot to mention that once we got the file, we were able to send the file without a problem, and we actually verified that the module was working by powering it on before we shipped it. It wasn't until the mechanic installed it on to the machine that the problem came up. 

For address 0 on and MD3, no IdTag is needed. 


I think you might have a VREF error on the machine.

There used to be a problem with VREF error causing IdTag error on the MD3, this was later fixed in 5.02

https://divapps.parker.com/divapps/iqan/Downloads/IQANdesign%205/ReleaseNotes5.08.1.htm#IQANdesign%205.02.11%20(8%20Mar%202018)

30982

MD3: Wrong IdTag message when starting with VREF error

Happened when no IdTag is used.
Fixed.

Possible causes for a VREF error may inlcude extreme undervoltage, but a simple VREF wiring error or overload could also cause this symptom.


An older MD3 before SN 214040001 (2012, week 14) does not have the hardware to read an IdTag, the software will not attempt to read the IdTag (thus no error) and it will always be address 0.