0
Fixed

MD4 won't display unicode character for omega

705David 1 year ago in IQANdesign updated by Gustav Widén (System support) 5 months ago 3

I am able to enter the unicode character for omega (Ω) into a display page for an MD4 but the MD4 just displays a blank space wherever it is used. I tried displaying it as a Unit with a Value Control as well as plain text in a Label Control with the same results.

Is this a bug?

For reference I have IQAN Design 6.08.24.8136.

This is what the display page looks like in IQAN Design:

Image 3549

Here is the display on the MD4:

Image 3550

Thanks,

I'm not sure it helps (in fact I'm sure it doesn't) but Ive tried using the Less than(<) Greater than(>) and Up caret(^) and Down Caret on an MD4 and the < and > are fine, but the Up and Down Caret show up on a PC with Simulate, but not on the actual MD4....  I suspect that is an issue with Simulate at least....

Andy

+1

This is somewhere between bug and missing feature. 


The problem is that the Default font does not include all characters. The project check should find this and give a warning that informs you of this problem, but for Greek characters, the project check believes it is ok. 

See also:  Some characters work in simulator but not MD4 display / Software / IQAN

What you can do is to specify a different font than Default. 


Fixed

From 7.00, the project check will give a warning about the character being missing from the default font.