0
Started

MC43 FS Error Code When DIN Connected

Kevin Arscott 2 years ago in Master modules / MC4x updated by Gustav Widén (System support) 2 years ago 1

We have an application which uses MC43FS module. We get an error code showing 4 x red, 2 x amber, 1 x amber, 1 x amber, 4 x amber. I have isolated the fault to one wire which is causing this error code, C1:10. The manual shows this as VIN / DIN, but we have found when connecting 24V to this pin once the module is booted, all is fine, no error code is generated. If we connect 24V to this pin and power the module on we get the error code flash up, the module shuts down, no communication is possible.


I have used a different MC43 to test and same error is generated. I have also tested by only connecting power, address tag and C1:10 and I still get the same error with the scenarios listed above. Is this a fault or is there something we are doing wrong (perhaps the allocation of pins)? Its almost as if the pin should only be a VIN and only accept 5VDC max, or perhaps its a pull up instead of pull down, is this what the error code is stating? We are unable to tell what the detailed error code is, only 'stopped critical' is listed. I will send across the video file of the error flash.

Started

Hi Kevin,


There is a problem with a diagnostics function over-reacting. It happens if VIN-C,I,Q or W on an MC4xFS module is connected to >7V. But these pins are supposed to handed up to battery voltage, the problem is fixed in version 5.03. Release scheduled for next week.