0
Completed

Wrong IdTag! Error on MD4

Ethan Zeman 5 years ago in Master modules / MD4 updated by Gustav Widén (System support) 4 years ago 5
Our system runs with a MD4, 3 MC3s, and an XC21.

On two separate machines now (with identical systems) we have received customer reports of an issue of the IQAN system stopping functioning during machine operation.

On the MD4, the screen will say STOP System Message: IQAN-Master Wrong IdTag! system

I have been told that power cycling will not fix the issue. The only way to resolve is to unplug the Deutsch connector from the back of the MD4 and then plug it back in.

This is an intermittent issue. The machines can run 100+ hours before the issue repeats.

The customer was advised to check resistance on the ID Tag (resistance was correct) and to check the pins and wiring condition at the MD4 for any anomalies or corrosion (nothing identified).

Do you have any guidance on this issue?

Under review
That is strange.
The module only reads its IdTag during start-up, so if this is happening during operation, that seems to indicate that something, e.g. a glitch in the power supply, is causing the MD4 to restart.

Are you sure the report about it occurring during machine operation and not during machine start is correct?

The most probable wiring fault for the IdTag would be an open circuit, but for that fault you would get a different error message, that would instead say "Safe mode! Application not loaded".

One guess, that is really just a guess, is that perhaps there could be an issue with a really low supply voltage. This is not something I have ever seen, but since the IdTag is using a 5V reference to measure the IdTag resistance, a supply <5V could perphaps in theory cause an incorrect measurement. But I have never seen this happening, it is just a thought.
Thank you Gustav. I will followed up with the customer. According to them it definitely occurred during operation although this information is being passed from an operator, to an electrician, to me, and then to you so we can remain skeptical of this.

The probed for follow up information and have some updated details: The last time this happened on a machine the operator turned power on and off to the MD4 though the ignition switch 5 times. Each time the same error occurred on start up. The issue happened at night so the machine was turned off and sat unpowered for 6 hours. The next morning the electrician got onto the machine and started it up. Again, the same error occurred. It was not until he unplugged the connector and plugged it back into the MD4 that the problem was resolved.

He said the connector did not seem loose and was fully clipped into the module before he removed it and plugged it back in.

Besides the fact that you are reseating the connection between the pins and sockets is unplugging the connector from the MD4 causing any type of internal reset inside the MD4 module which would not be achieved by power cycling?



Since unplugging the C1 connector and plugging it back in resolved the issue, it is probable that there was something in the connector that altered the restance that the MD4 measured on the IdTag. Perhaps if they have applied some grease in the connector.
The message "Wrong IdTag" is given both if you have an IdTag with the wrong number (e.g. a 2 instead of a 1), but also when there is an invalid resistance that does not match the range for any of the IdTags.

For the MD4, power cycling the module (cutting the supply to the +BAT pin) has the exact same effect as unplugging the connector and plugging it back in. It will reboot, and at startup it will read the IdTag.
+1

After following up with the customer it appears the problem has been resolved. To the best of my knowledge the root cause was a faulty connection between the DT connector and module which was eventually resolved by unplugging the module and plugging it back in. Thanks for the support.

Completed

Good to hear the issue was resolved, thanks for letting us know.