0
Fixed

iqansimulate 4.07

Michael Carlyle 11 months ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 11 months ago 7

I upgraded to Iqansimulate 4.07.6.3943 and it does not pick up the license.  when I run from Iqandesign it will not simulate properly as it says it is running an evaulation license.  Same license runnign Iqansimulate 3 and Iqansimulate 5.02 work fine.


Is this a bug with iqanSmulate 4.07?  Do I have to reinstall Iqan Creative Studios 4?

0

IQAN Simulate, monitor issue.

Steve Liljestrand 12 months ago in IQANsimulate • updated by Anders Båth 12 months ago 2

The Last time I used IQAN Simulate 4.xx I had multiple monitors connected to my laptop via a docking station. now that I am using the laptop independently in the field the IQAN Simulate window is only partially showing far off to the right of my screen. I cant seem to correct this. when i click on the Upper bar of the window i get an error sound bit but no visible message. I imagine if I had my multiple monitors connected I would be able to move things around. any ideas? 


0
Fixed

'New Simulation' vs 'Last Used Simulation'

Lars Bolduc 1 year ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 8 months ago 3

Hello,


Is there supposed to be any consistency between the two options 'New Simulation' vs 'Last Used Simulation'? These are from the prompt given when starting a simulation of a project from IQANdesign.


I would like 'New Simulation' to start fresh and forget any information entered during previous simulation sessions, and I would think that 'Last Used Simulation' would do the opposite of that.


No matter which option I choose it seems completely random what will happen. Usually it remembers the previous session data, which is frustrating. I never directly save simulations, but I believe the autosave feature is what is doing this.


I have been able to observe this behaviour with both IQANsimulate 4.07 and IQANsimulate 5.


Is this feature broken or is it intended to do this?


Thank you.

0
Completed

Simulation Screenshots

Lars Bolduc 1 year ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 1 year ago 4

Hello,


I think it would be convenient to be able to grab a printout of what is on the simulated screen in a PNG or JPEG format. For documentation purposes primarily.


Right now Windows' Snipping Tool works but it's a very slow process and you have to be very precise. It also is impossible to get each screenshot to be the same size as the display's (MD4 in my case) screen.


Thank you.

Answer

I believe F12 during the simulation will grab screen shots.

0
Fixed

IQAN Design 5.01

Larri 1 year ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 1 year ago 3

I just downloaded IQAN Design 5.01 and now I am having issues with
Public channels not showing up in Simulator Mode.  I did not have this
issue in version 5.0.  Any suggestions?

EDIT MODE


 SIMULATE MODE

0
Answered

Generic CAN and simulation

PekkaA 2 years ago in IQANsimulate • updated by Jack 4 months ago 3

I have a design involving MD4 and MC2 multimaster setup in a Generic CANbus. MC2 feeding values to MD4 via CAN. When I run the simulation of the design the values do not seem to pass on to MD4 display. I have double checked the CAN frame address and field definitions and they are ok.


However, if I create a Simulation group for MD4 and get the channel updated directly from MC2, then I can see the value changing. But I'd guess this bypasses CAN messaging completely and uses Simulator's own message passing mechanisms.


Is Generic CAN messaging simulation something that is not supported? Or am I doing some fundamental mistake here?

0

Allow Simulation Change of Value with FGI

Joe 2 years ago in IQANsimulate • updated by Gustav Widén (System support) 2 years ago 1

It would be really nice to be able to use the FGI channel to change the underlying value of the referenced channel when simulating. Otherwise it appears that it is required to navigate to and from different function groups in order to change the value and subsequently see the results of the change. If there is another method, please advise. Thanks

0

Simulator problem

Krzysztof Bręk 2 years ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 2 years ago 2

I have a problem with my IQAN simulate. When I run my project, aplication showing error problem

Answer
Anders Båth 2 years ago

I just got your submitted bug report on IQANsimulate. It looks like there is a problem with one of the logs in the MD4 simulator. If you find and delete the log files for the simulated project it should work again. IQANsimulate stores the log files in the following folder:


C:\Users\<username>\AppData\Local\IQANsimulate 4\<Project ID>\<Module type-Address>\Logs


- Replace <username> with your windows username

- Replace <Project ID> with the id of your project (can be found in project statistics in IQANdesign)

- Replace <Module type-address> with e.g. MD4-7-0 for and MD4-7 with address 0.


If you want you can submit the log files to us for examination before deleting them (maybe we can get some clues to why they will not load). In that case you can use this link: https://iqan.sharefile.com/filedrop


0
Fixed

iQan Simulate 4.02.5.3440 MD4 bug

David Dufour 3 years ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 2 years ago 13

I just updated to the Version 4.02.5.3440 and I'm unable now to see the start page on the screen. The only thing I have is the version number on the bottom right of the panel.


It work with a MD3 program.


To do the test, I use the demo program from Parker.

The MD3 demos work correctly, but all MD4 demos won't.




0
Answered

How to apply a license with unattended setup

Gompo 3 years ago in IQANsimulate • updated by Ulrik Zakariasson (Software development) 3 years ago 3

Is there a way to deploy IQANrun and IQANsimulate2 with an unattended, silent setup AND to also apply our license information?