0
Fixed

BSOD on MD4

Michael Carlyle 4 years ago • updated by Gustav Widén (System support) 4 years ago 5
We are having trouble with Blue Screen Problems with Iqan MD4 when running 3.16 and higher (ever since the cycle time was allowed to be lowered below 25 ms). Running the cycle time higher decreases the occurrence rate. They occur mostly at startup so it is impossible to graph the system utilization.

It did not seem to happen in 3.14.

I have tried updating to 3.18 as there seemed to be some fixes for Blue screen problems but it is still happening.
0

XC10 output high in software but low directly on module

Kevin Arscott 4 years ago in IQANdesign • updated by Gustav Widén (System support) 3 years ago 7

We experienced a similar issue with output energisation that was corrected in 3.16 but this is slightly different.



System is 1 MD4 with XC10 as expansion, 1 MC3 and 1 MC3 with XC10 expansion. We have logic that switches a single DOUT on XC10 expansion connected to MD4. This logic is handled in MD4 application. With a delay on of 500ms or less the output on XC10 remains low on module (tested using multimeter) but IQAN design when connected says high.



If I increase delay on to 1000ms the output switches on and voltage present on XC10 module using multimeter.



Its almost as if the MD4 is sending a command to energise output before XC10 has booted?

I have rigged up single MD4 and XC10 on the bench but been unable to replicate, perhaps cycle time of the software could be the issue? Running IQAN Design 3.19.

0
Completed

Trial License - what does it permit and prevent - document this

David Holcomb 4 years ago • updated by Ulrik Zakariasson (Software development) 4 years ago 2
we have customers regularly questioning exactly what they can and cannot do with the trial license.

During installation, it mentions connection only with simulator, etc. This is very clear and defined , but only available during installation. If this could be added to the manual or a separate document this would let us have a standard answer for customers.
Answer
In 3.17, (to be released next week), the 30 day limit is removed. You can use the tools without a license as long as you like. The functional limitations are still there though, the tools are limited to simulation only.
0
Not a bug

Cycle time effects timer counting 3.18

Kevin Arscott 4 years ago in IQANsimulate • updated by Gustav Widén (System support) 3 years ago 5
I have an application (1 MC3) that uses a timer which seems to count 10000 ms correctly with real time when the cycle time is set to 50ms. This is how I would expect it to behave.

When I reduce the cycle time of the application down to 5ms the time taken to get to 10000ms in the MC3 application takes approx. 20000ms in real time. Its almost as if the timer counting has slowed down when I reduce the cycle time.

I have tried as a new application file with simply just a timer counter in and no other logic as I wondered if I was approaching the processing limit but the inaccuracy still appears present?


I haven't tried previous versions of software and been unable to test in a real application so I can only assume this could be an issue with simulate and not IQAN Design?

0
Answered

rotating picture

Masia Jean-Baptiste 4 years ago in IQANdesign • updated by Ulrik Zakariasson (Software development) 2 years ago 10
Hello

It is possible to rotate a picture with a mathematical function ?

best regard
0
Answered

What kind og iqan?

Ruben Bortelid 3 years ago • updated by Roger Sandberg 2 years ago 9

hello and thanks for this great forum.

A have an 2001 IllerIller tdi tracked vehicle, made in Sweden. The driving system is controlled by a iqan system. I attached a picture of the screen. Is there anybody how can tell my what version of iqan it is, and what software a need for adjust parameters? I find a rs232 cable behind the seat, and I guess it is for programming iqan.


0
Fixed

Unsuccessful MD4 program update using IQAN Design 3.15

Manny 4 years ago in IQANdesign • updated by Ulrik Zakariasson (Software development) 4 years ago 6
Hello all, 

New to forum. Looking forward to all the knowledge base available here. 

To kick it off, I have encountered a situation where loading of an IQAN Design program from version 3.15 into an MD4 proves unsuccessful. IQAN Design will load firmware resources 21/21 and gets hung up on "Waiting on MD4". While on the MD4, there is a blue screen with the last line of text saying "CRC OK". I've let it sit there for 20 minutes with no change in status.

However, when loading a IQAN Design program from version 3.11 (have not tested 3.12 - 3.14) to the same MD4, no blue screen. Is this is a known bug and will it be addressed in 3.16? Is there a workaround in the meantime? 

Thank you all in advance and once again, looking forward to forum. 

-Manny
0
Answered

Module communication failure when updating to V3.19.9

Kevin Arscott 3 years ago • updated by Ulrik Zakariasson (Software development) 3 years ago 3

We have a system (2 x MC£, 1 x MD4) running V3.19.7 and decided to update to version 3.19.9. Sent program over CAN communication tool and machine appeared to update to 3.19.9. After completion of update one module wasn't communicating over the master bus. This isn't unusual. We cycled ignition (which usually fixes error) and the module still failed to communicate. We have got this module into an endless cycle giving CAN error. Is this as a result of updating from 3.19.7 to 3.19.9?

0

backlight in multi display setup

Ed Schippers 4 years ago in IQANdesign • updated by Gustav Widén (System support) 4 years ago 1
Multi display setup, MD4-7” (master) and MD4-5” (non touch) I want the backlight of the 5” display to match the 7” It would be nice if this could be done by using the backlight setting of the master by means of a system information output or an option in the backlight control setting of the other display to bind it to the setting of the master. Instead of an extra adjustable parameter.

Regards,

Ed
0
Fixed

event counter reset reverting to the wrong number - suspicious possibility

Zach 4 years ago in IQANdesign • updated 3 years ago 18
Does anyone else seem to have a gremlin changing your event counter reset values?

It has happened a few times to me.